Vista/Windows 7 - AWC says I need to log in as admin

Post any queries/problems regarding registration of AWC here. Do NOT post registration details in your post: if I need that information from you I will reply to you by email so you can send it privately.

Vista/Windows 7 - AWC says I need to log in as admin

Postby SteveM_Admin » Wed Mar 18, 2009 5:50 pm

Do you have UAC (User Access Control) turned on in Vista? If so it would explain why AWC thinks you don't have the appropriate privileges. Even when logged in as an admin the operating system still tries to protect you from yourself by refusing admin access to most applications unless they are specifically flagged as being admin level applications.

Of course in general you don't want an application like AWC to have greater privileges than any other standard app, but when you are registering, AWC needs access to an area of the system registry (HKLM/Software) that is protected. This is because all users of the PC need to be able to read the registration codes to run AWC.

The solution is fairly straightforward: first exit from AWC and then launch it again but this time with full admin rights. To do that right click on the program icon and select the ‘Run as administrator’ command from the list of menu choices. You should now be able to perform the registration successfully.

Note for Windows 7 users: Win7 is a bit smarter about how it deals with User Access Control but problems can still occur. The error reported might be slightly different but the solution above will still work.

Regards

Steve Murphy
Last edited by SteveM_Admin on Sat Sep 11, 2010 1:51 pm, edited 3 times in total.
Reason: Added short note for Windows 7 users
SteveM_Admin
Site Admin
 
Posts: 679
Joined: Thu Jan 01, 1970 1:00 am
Location: Bolton, England

Return to Registration Issues

Who is online

Users browsing this forum: No registered users and 0 guests

cron